Prüfung je nach Release? Thema ist als GELÖST markiert

Getting started ... Alles für einen gelungenen Start.
6 Beiträge • Seite 1 von 1
6 Beiträge Seite 1 von 1

Prüfung je nach Release?

Beitrag von generic_user (ForumUser / 15 / 2 / 0 ) » 13.09.2019 10:52
Hallo zusammen,

kennt jemand eine Möglichkeit ein Report zu Prüfen (Strg+F2) dabei soll aber nicht aktuelles installiertes SAP-Release, sondern einer der älteren berücksichtigt werden?
Sprich: ich muss auf jungeren Release entwickeln können und auf ältere Mashine dann ausliefern.

VG
GU


Re: Prüfung je nach Release?

Beitrag von ewx (Top Expert / 4199 / 193 / 436 ) » 13.09.2019 11:32
Du kannst die sourcen auf github hochladen und siehst dann eine Übersicht der Releasekompatibilität mit Hilfe von ABAPlint:
https://stats.abaplint.org/#/-/larshp/abapOpenChecks

Folgende Benutzer bedankten sich beim Autor ewx für den Beitrag (Insgesamt 2):
generic_user (13.09.2019 14:21) • fr-g (16.09.2019 11:14)


Re: Prüfung je nach Release?

Beitrag von generic_user (ForumUser / 15 / 2 / 0 ) » 13.09.2019 11:59
Hi ewx,

danke dir, ist auf jedenfall ein Einsatz.

Wenn jemand eine SAP interne Lösung kennt...

VG
GU

Re: Prüfung je nach Release?

Beitrag von fr-g (ForumUser / 56 / 6 / 18 ) » 16.09.2019 11:29
Ich habe es selber nicht ausprobiert, aber der Code Inspector erlaubt wohl einen Remote Syntax Check:

https://blogs.sap.com/2014/11/28/remote ... evelopers/

Folgende Benutzer bedankten sich beim Autor fr-g für den Beitrag (Insgesamt 3):
generic_user (16.09.2019 11:37) • ewx (16.09.2019 11:37) • deejey (16.09.2019 20:20)


Re: Prüfung je nach Release?

Beitrag von generic_user (ForumUser / 15 / 2 / 0 ) » 16.09.2019 11:45
Das sieht danach aus, was ich gesucht habe, danke dir.
Muss nur noch passendes System einbinden, dann kann ich es testen.

Re: Prüfung je nach Release?

Beitrag von IHe (ForumUser / 52 / 17 / 16 ) » 17.09.2019 10:42
Schade, wir entwickeln auf 7.40 SP11 (+7.51 SP02 für S/4HANA-spezifische Enhancements) und hätten noch eine Sandbox mit 7.00 SP12 für die Prüfung auf Abwärtskompatibilität, jedoch gibt es dort den Remote-Fuba für SCI noch nicht...

Aber die Möglichkeit über github + ABAPlint klingt sehr spannend, sofern das nicht nur mit Z/Y-Paketen geht.

Seite 1 von 1