Workflow: eMail Versand

Alles rund um die Sprache ABAP®: Funktionsbausteine, Listen, ALV
3 Beiträge Seite 1 von 1
3 Beiträge Seite 1 von 1

Workflow: eMail Versand

Beitrag von bapimueller (ForumUser / 58 / 3 / 0 ) » 21. Aug 2019 18:04

Hallo,
ich hoffe ich habe das richtige Forum erwischt. Ich habe einen WF bei der MatStamm Anlage mit verschiedenen Prüfschritten angelegt. Vor jedem Schritt habe ich einen Schritt zum Versand einer zusätzlichen eMail/Info an den möglichen Sachbearbeiter eingebaut (Kundenwunsch, das WI ist nicht ausreichend).
Dieser eMail Schritt ruft die folgende Methode:
BO: SELFITEM, Methode: SENDTASKDESCRIPTION
Empfänger: Org Objekt

Den Rep. RSWUWFML2 habe ich mit einer entsprechenden Variante als Job eingeplant.

In der SOST finde ich keinen ausgehenden Sendeauftrag, allerdings sagt mit das WF-Protokoll, dass der eMail Schritt beendet ist.

Was fehlt noch, damit in der SOST der Sendeauftrag erscheint?

Viele Grüße,
Thomas
Thomas Müller
SAP Beratung
M: +49 (0) 173 / 870 39 31
T: +49 (0) 6228 / 924 560
F: +49 (0) 6228 / 924 559


Re: Workflow: eMail Versand

Beitrag von a-dead-trousers (Top Expert / 3253 / 84 / 820 ) » 21. Aug 2019 20:39

Hi.

Ist die eMail rausgegegangen?
Wenn ja würde ich darauf tippen, dass die Versandeinstellung auf "sofort" eingestellt wird. Dann erscheinen glaub ich keine Ausgangsaufträge in der SOST. Ansonsten würde ich darauf tippen, dass der WF irgendwo ein Rollback Work (oder kein Commit Work) macht und somit der Email-Versand nicht korrekt verbucht wird.

lg ADT.
Theory is when you know something, but it doesn't work.
Practice is when something works, but you don't know why.
Programmers combine theory and practice: Nothing works and they don't know why.

ECC: 6.07
Basis: 7.40

Re: Workflow: eMail Versand

Beitrag von SaskuAc (Specialist / 267 / 24 / 33 ) » 22. Aug 2019 06:45

Bin da auf a-dead-trousers Seite - vermutlich hast du irgendwo einen Rollback work drinnen ( eventuell ist das auch in einem FuBa oder klasse die du aufrufst.. )
Versuch doch einfach mal den zu der BO-Methode dahinterliegenden FuBa ( SWO_INVOKE wenn ich das richtig im kopf habe ) zu debuggen, wenn du den Workflow an die Stelle gebracht hast.
Beim Debugging müsstest du sehen ob irgendwo ein Fehler liegt.

Wenn kein Fehler vorliegt und alles wie erwartet ohne Fehler durchläuft, wird vermutlich der erste Punkt von a-dead-trousers stimmen, dass das System bei euch so eingestellt wurde, dass man raus gegangene Mails nicht mehr in der SOST sieht.

Seite 1 von 1

Aktuelle Forenbeiträge

SELECT-OPTIONS: NO INTERVALS auch in Fenster Mehrfachselekti
vor 26 Minuten von DeathAndPain 7 / 7179
Lookup Tabelle in Methode lesen und erweitern
vor 35 Minuten von DeathAndPain 7 / 135
ABAP Editor gelöst
vor einer Stunde von DeathAndPain 7 / 122
Fehler bei F4-Hilfe
vor einer Stunde von DeathAndPain 5 / 101

Unbeantwortete Forenbeiträge

Mini-SAP Einstiegs Logo ändern
vor 21 Stunden von Tron 1 / 85
Absenderland in Transaktion BP setzen
Gestern von SAP_ENTWICKLER 1 / 73
Funktionsbaustein QPMK_MSTCHA_VERS_CREATE
vor einer Woche von SAP_ENTWICKLER 1 / 104
OLE 2 Excel Datum konvertieren
vor einer Woche von Kerstin 1 / 93