gelöst Hotlink: Parameter ID wird nicht akzeptiert


Alles rund um die Sprache ABAP®: Funktionsbausteine, Listen, ALV

Moderatoren: Jan, Steff

gelöst Hotlink: Parameter ID wird nicht akzeptiert

Beitragvon Legxis » 25.05.2018, 09:35

Hallo, ich baue gerade einen Report. Dieser enthält einen Hotlink. Allerdings gibt es ein Problem bei dem Parameter ID, diesen akzeptiert er für die Transaktion nicht. Wenn ich auf den Hotlink klicke geht er also in die Transaktion und zeigt mir dann einen Fehler an.
Der Parameter der Transaktion ist korrekt, das habe ich geprüft.
Und im Debugger habe ich mal nachgeschaut, ob er das richtige Werk in dem Parameter gespeichert hat, und das hat er! Deshalb verstehe ich nicht, was das Problem ist.

Ich weiß nicht, ob ihr da helfen könnte, da die Transaktion kundeneigen ist, aber vielleicht hatte schonmal jemand Probleme mit Parameter IDs oder hat noch eine Idee?

Code: Alles auswählen
READ TABLE gt_outtab INTO wa_outtab INDEX row.

    IF sy-subrc = 0.

      CASE column.

        WHEN 'WERKS'.
          SET PARAMETER ID 'WRK' FIELD wa_outtab-werks.
          CALL TRANSACTION 'ZWERK03' AND SKIP FIRST SCREEN.
 


Bild

EDIT: Natürlich, ich suche die ganze Zeit, schreibe dann endlich einen Post und genau danach finde ich den Grund. https://blogs.sap.com/2013/10/18/user-parameter-value-not-pulled-into-the-transaction/ Tja, dann werde ich wohl erstmal keinen Hotlink verwenden können.
Ich bin dankbar für jede Hilfe, Kritik, diverse Programmverbesserungen/-optimierung und schöne Codebeispiele^^
( SAP ECC 6.0, NetWeaver 7.0, ohne unicode, ohne support/enhancement packages )
Legxis
Specialist
 
Beiträge: 127
Registriert: 12.01.2018, 08:59
Wohnort: Köln
Dank erhalten: 20 mal
Ich bin: Student/in

Sponsor

Alte ABAP-Entwicklerweisheit: Weißt du weder aus noch ein, baust du einen BADI ein

Zurück zu ABAP® Core

  Aktuelle Beiträge   
Java & Bildbearbeitung
vor 13 Stunden von Madredure 0 Antw.
Call Transaction WE20 mit Werteübergabe
vor 12 Stunden von ewx 1 Antw.
Vergleich Customizing Tabellen auf zwei Systemen
vor 13 Stunden von ewx 2 Antw.
Empfehlung Antiviren-Programm?
vor 14 Stunden von Madredure 2 Antw.
BADI im Customizing finden
Gestern von Romaniac 0 Antw.

  Ähnliche Beiträge beta
SET PARAMETER-ID funktioniert nicht
11.05.2004, 22:27 von Chrisu 6 Antw.
Parameter muß breiter, doch er will nicht
24.03.2004, 18:48 von Volker Neurath 3 Antw.
Parameter auf nicht eingabefähig setzen
06.09.2005, 10:51 von cosmo 2 Antw.
VBUP wird nicht upgedated
30.08.2004, 09:08 von FBO 3 Antw.
Verbuchungsfunktionsbaustein wird nicht aufgerufen
01.11.2005, 17:16 von solyomvari 0 Antw.

 

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder