gelöst Defaultpaket in Eclipse


Getting started ... Alles für einen gelungenen Start.

Moderatoren: Jan, Steff

gelöst Defaultpaket in Eclipse

Beitragvon Thomas R. » 23.03.2018, 13:17

Hallo zusammen,
z.Z. versuche ich die Eclipseumgebung etwas kennen zu lernen.
Dabei stoße ich bereits am Anfang auf das Problem, dass ich nicht alle Entwicklungspakete als Favorit einbinden kann.
Es scheint so zu sein, dass alle Pakete, bei denen das Feld AS4USER in der TDEVC leer ist, nicht angezeigt (und eingebunden werden können).

Wo kann ich dieses Feld denn füllen? Beim Anlegen eines Pakets aus der SE80 heraus wird es nicht abgefragt.

Irgendwo bin ich gerade etwas verpeilt - wer nimmt mir die Tomaten von den Augen?

MfG
Thomas R.
Thomas R.
Expert
 
Beiträge: 669
Registriert: 11.12.2002, 08:04
Dank erhalten: 25 mal

Sponsor

Alte ABAP-Entwicklerweisheit: Weißt du weder aus noch ein, baust du einen BADI ein

Re: Defaultpaket in Eclipse

Beitragvon SaskuAc » 26.03.2018, 06:40

Also soweit ich das hier sehe liegt es daran, dass in der "Hierarchie" kein AS4USER Wert angelegt ist. In unserem Standard HR-Paket ist das Feld gefüllt, in meinem unterpacket ( für SuccessFactors ) nicht, allerdings habe ich dieses in meinen Favoriten eingebunden. Heißt, es muss zumindest in der Gesamthierarchie einen geben.

Soweit ich das bei unseren Z-Paketen sehen kann sind so gut wie alle Unterpackete so eingestellt, dass das Feld nicht gefüllt wird, eventuell muss im Anschluss explizit jemand angegeben werden, wenn es gefüllt sein soll. Sicher bin ich mir allerdings nicht.

Für diese Nachricht hat SaskuAc einen Dank bekommen :
Thomas R.
SaskuAc
Specialist
 
Beiträge: 208
Registriert: 01.06.2015, 10:16
Dank erhalten: 19 mal
Ich bin: Entwickler/in

Re: Defaultpaket in Eclipse

Beitragvon erp-bt » 26.03.2018, 07:07

Hallo,

Kann ich nicht bestätigen, bei mir werden auch Pakete als Favorit gespeichert, in denen das Feld AS4USER nicht gefüllt ist.

Viele Grüße,
...entwickelnder Berater...beratender Entwickler

Für diese Nachricht hat erp-bt einen Dank bekommen :
Thomas R.
erp-bt
Specialist
 
Beiträge: 147
Registriert: 14.05.2008, 10:49
Dank erhalten: 16 mal

Re: Defaultpaket in Eclipse

Beitragvon Thomas R. » 26.03.2018, 17:54

Hallo und vielen Dank für die Tipps.
In der Zwischenzeit kenne ich einen Workaround.
Andere Anmeldesprache im Eclipsepaket.

Das Paket wurde mit Anmeldesprache Englisch in der SE80 angelegt.
Bei einem Eclipseprojekt mit Anmeldesprache Englisch sehe ich das Projekt nicht, aber bei einem Eclipseprojekt mit Anmeldesprache Deutsch.
Seltsam, aber ist so.

Wir arbeiten hier normalerweise mit Deutsch - so ist unser SAP auch installiert(!) worden. Ob das die wirkliche Ursache ist kann ich im Moment nicht beurteilen.

Danke für Euer Mitdenken!

Thomas R.

P.S: Nur ein (schlechter) Workaround, keine echte Lösung, deshalb auch nicht auf gelöst gesetzt.
Thomas R.
Expert
 
Beiträge: 669
Registriert: 11.12.2002, 08:04
Dank erhalten: 25 mal

Re: Defaultpaket in Eclipse

Beitragvon Thomas R. » 26.03.2018, 18:16

Hallo und willkommen zu einem Wunder von SAP (und eclipse)

Nachdem ich in der SE80 mit __deutschen__ Logon das Paket gepflegt hatte und eclipse erneut gestartet hatte
ist das Paket in eclipse auch mit englischem Logon sichtbar.

Ohne zu wissen woran es jetzt genau lag :twisted: ist das Problem doch gelöst! :o

Thanks to all
Thomas R.
Thomas R.
Expert
 
Beiträge: 669
Registriert: 11.12.2002, 08:04
Dank erhalten: 25 mal


Zurück zu ABAP® für Anfänger

  Aktuelle Beiträge   
s4hana-cloud
vor 8 Stunden von sap_inchen 1 Antw.
500 Internal Server Error
vor 16 Stunden von zzcpak 1 Antw.
Dokumentinformationen lesen vom DVS
vor 18 Stunden von Tron 4 Antw.
Tabs innerhalb von Tabs
vor 19 Stunden von ewx 4 Antw.
Fakturierungsplan in Kontrakten ändern
vor 15 Stunden von DeathAndPain 1 Antw.

  Ähnliche Beiträge beta
gelöst ABAP in Eclipse Muster
08.09.2016, 09:17 von SaskuAc 1 Antw.
Eclipse-Einstellungen migrieren
17.10.2017, 17:12 von black_adept 1 Antw.
ABAP für Eclipse: Wo findet man die Change Logs?
13.02.2018, 23:13 von deejey 7 Antw.

 

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder