gelöst SET PARAMETER funktioniert nicht richtig


Getting started ... Alles für einen gelungenen Start.

Moderatoren: Jan, Steff

gelöst SET PARAMETER funktioniert nicht richtig

Beitragvon Tommy Nightmare » 04.01.2019, 10:23

Hallo und frohes Neues,

Ich möchte in einem Programm einen Userparameter setzen.

Code: Alles auswählen
SET PARAMETER ID 'ZPARA' FIELD 'X'.
COMMIT WORK AND WAIT.
 


Der Parameter steht in der Tabelle tpara und im Debugger bleibt sy-subrc nach beiden Anweisungen auf 0.

Wenn ich dann in die SU01 gehe und meinen User anschaue, wurde der Parameter aber nicht gesetzt.

Meine Frage ist jetzt: Kann man mit SET PARAMETER auch permanent Parameter setzen oder sollte man für solche Zwecke den Fuba BAPI_USER_CHANGE benutzen?

LG Tommy
Tommy Nightmare
ForumUser
 
Beiträge: 27
Registriert: 08.09.2017, 11:38
Dank erhalten: 1 mal
Ich bin: Entwickler/in

Sponsor

Alte ABAP-Entwicklerweisheit: Weißt du weder aus noch ein, baust du einen BADI ein

Re: SET PARAMETER funktioniert nicht richtig

Beitragvon Somani » 04.01.2019, 11:05

Hallo

Für die dauerhafte Speicherung des Parameters benutze ich die Funktion SMAN_SET_USER_PARAMETER.

Grüsse

Für diese Nachricht hat Somani einen Dank bekommen :
Tommy Nightmare
Somani
ForumUser
 
Beiträge: 61
Registriert: 23.07.2010, 17:07
Dank erhalten: 16 mal
Ich bin: Entwickler/in

Re: SET PARAMETER funktioniert nicht richtig

Beitragvon Tommy Nightmare » 04.01.2019, 11:42

Danke für die Info, jetzt funktionierts
Tommy Nightmare
ForumUser
 
Beiträge: 27
Registriert: 08.09.2017, 11:38
Dank erhalten: 1 mal
Ich bin: Entwickler/in


Zurück zu ABAP® für Anfänger

  Aktuelle Beiträge   
Applikations-Toolbar dynamisch erzeugen
vor 8 Stunden von ralf.wenzel 0 Antw.
CP_BD_DIRECT_INPUT_PLAN
Gestern von Gottschall 0 Antw.
Logische Datenbank: Selektieren mit Loop
vor 4 Stunden von deejey 12 Antw.
Globale Konstanten - Organisationseinheiten
vor 13 Stunden von ralf.wenzel 5 Antw.
Kein Zugriff auf Dateien im Applikationsserver
Gestern von zzcpak 1 Antw.

  Ähnliche Beiträge beta
Select funktioniert nicht richtig
29.03.2012, 11:46 von Explode 1 Antw.
Schreiben auf Datenbank funktioniert nicht richtig
14.11.2006, 09:26 von an4kh4 2 Antw.
ALV ließt Daten aus Excel nicht richtig aus
22.09.2011, 06:51 von a-dead-trousers 1 Antw.
Datumsfeld wird nicht richtig formatiert
16.12.2013, 13:13 von ewx 6 Antw.
SELECT OPTIONS filtert nicht richtig
22.06.2015, 08:08 von Thanatos82 1 Antw.

 

Wer ist online?

Mitglieder in diesem Forum: Google Adsense [Bot]