Problem bei ALV-Ausgabe

Getting started ... Alles für einen gelungenen Start.
3 Beiträge • Seite 1 von 1
3 Beiträge Seite 1 von 1

Problem bei ALV-Ausgabe

Beitrag von Patrick1982 (ForumUser / 20 / 3 / 0 ) »
Moin zusammen,

ich habe eine itab lt_customer_all, die ich als ALV ausgeben möchte. Das klappt mit folgendem Code soweit auch:

Code: Alles auswählen.

  TRY.
      CALL METHOD cl_salv_table=>factory
        EXPORTING
          list_display = if_salv_c_bool_sap=>false
        IMPORTING
          r_salv_table = lr_salv
        CHANGING
          t_table      = lt_customer_all.
    CATCH cx_salv_msg INTO lr_err_salv.
      "Fehler anzeigen
      lv_string = lr_err_salv->get_text( ).
      MESSAGE lv_string TYPE 'E'.
  ENDTRY.

  "Spaltenbreite optimieren
  lr_columns = lr_salv->get_columns( ).
  lr_columns->set_optimize( abap_true ).

  "eigentliche Anzeige
  lr_salv->display( ).
Allerdings kann ich das Ergebnis leider nicht nach Excel exportieren. Es gibt keine Symbolleiste und im Menü oben ist leider alles ausgegraut.
Was hab ich falsch gemacht bzw. was fehlt noch?

Vielen Dank und viele Grüße,
Patrick


Re: Problem bei ALV-Ausgabe

Beitrag von Thomas R. (Expert / 715 / 45 / 30 ) »
Hallo Patrick,
Du musst die Funktionalität erlauben:
lr_salv->get_functions( )->set_all( ).
(vor dem display)

MfG
Thomas R.

Re: Problem bei ALV-Ausgabe

Beitrag von Patrick1982 (ForumUser / 20 / 3 / 0 ) »
Top, danke! :)

Seite 1 von 1

Über diesen Beitrag



Unterstütze die Community und teile den Beitrag für mehr Leser und besseren Inhalt:

Aktuelle Forenbeiträge

F4 Hilfe für Dynprofeld
vor 13 Stunden von ewx gelöst 6 / 46

Vergleichbare Themen

erl. ABAP2xlsx - Problem mit der Ausgabe
von Thomas17 » 05.12.2012 15:47
Problem ALV-GRID Ausgabe
von TobiB » 17.10.2007 17:31
ALV Ausgabe Zeilen Problem
von erzoo24 » 10.07.2015 09:58
Problem mit Feldkatalog zur Ausgabe im ALV-Grid
von Gast » 22.11.2004 11:53
Problem Ausgabe Interne Tabelle !?!?!?
von Gast » 03.11.2004 10:19