CL SALV_TREE - REfresh oder Neuaufbau - Probleme

Alles rund um die Sprache ABAP®: Funktionsbausteine, Listen, ALV
3 Beiträge • Seite 1 von 1
3 Beiträge Seite 1 von 1

CL SALV_TREE - REfresh oder Neuaufbau - Probleme

Beitrag von JohnLocklay (Specialist / 173 / 28 / 2 ) »
Moin Community.

ich hab mir mit der Klasse cl_salv_tree einen eine Baumstruktur aufgebaut.
Jetzt will ich einen neuen Knoten hinzufügen und danach das ganze neu Aufbauen.
Wie refreshe ich das ganze richtig?
Anscheinend sind meine Parent Notes alle noch da was zum Dump führt.

Ich rufe auf
mo_nodes->get_all_nodes( ).
mo_nodes->delete_all( ).
cl_gui_cfw=>flush( ).

Dann erstelle ich die komplette Struktur des Trees mit den neuen Informationen aus der Itab neu auf.

Wenn ich witzigerweise alle Refs der Attribute kille (free mo_tree, free mo_nodes usw) und die Factory neu Aufrufe gibt es keinen Dump. Aber es wird auch nur ein Screen angezeigt ohne Knoten. Als ob sich ein Container darüber gelegt hat.

Ich benutze die Factory Methode des Trees ohne Exporting Container.
Hab ich vergessen was abzubauen?

Bei ALV´s gibts ne FREE Methode, die scheints beim SALV_TREE nicht zu geben.
Danke für euer Feedback
Code once - Think twice


Re: CL SALV_TREE - REfresh oder Neuaufbau - Probleme

Beitrag von Lukas Sanders (ForumUser / 18 / 5 / 11 ) »
Moin,

die Methode SET_DATA würde ich noch ausprobieren. Die müsste eigentlich alles neu aufbauen.

Re: CL SALV_TREE - REfresh oder Neuaufbau - Probleme

Beitrag von ewx (Top Expert / 4306 / 207 / 464 ) »
Warum fügst du nicht einfach nur den Knoten hinzu?

Seite 1 von 1

Vergleichbare Themen

SALV Refresh
von Mustafapmk0 » 06.02.2017 15:50
SALV Refresh funktioniert nicht
von Abapanfänger » 27.08.2019 12:48
Probleme mit Tree Status
von Gast » 14.04.2004 13:51
Neuaufbau Entwicklungssystem: Versionsdatenbank sichern ?
von tku » 03.03.2006 10:59
Doku über ALV Tree / SAP Tree
von SkyHobbit » 14.06.2005 11:56